summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2013-03-18 10:39:50 -0400
committerJakub Hrozek <jhrozek@redhat.com>2013-03-20 12:38:56 +0100
commit8c294c1cd4d721818a59684cf7f2b36123f79163 (patch)
treee85a420907c8b3fe3cb268ec34913fd5df0fb337 /Makefile.am
parentec26d836b1b2a41ec2692976a539da51f261412b (diff)
downloadsssd-8c294c1cd4d721818a59684cf7f2b36123f79163.tar.gz
sssd-8c294c1cd4d721818a59684cf7f2b36123f79163.tar.xz
sssd-8c294c1cd4d721818a59684cf7f2b36123f79163.zip
BUILD: Always run distcheck and RPM tests in /dev/shm
Some of the tests (such as the sysdb tests) are highly I/O limited. By running them on a ramdisk, we can significantly speed up the test runs when doing a distcheck or RPM build. https://fedorahosted.org/sssd/ticket/1840
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 9dbde0391..39e6e0745 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,11 @@
+extra_distcheck_flags =
+if HAVE_DEVSHM
+ extra_distcheck_flags += --with-test-dir=/dev/shm
+endif
+
DISTCHECK_CONFIGURE_FLAGS = --with-ldb-lib-dir="$$dc_install_base"/lib/ldb \
- --enable-all-experimental-features
+ --enable-all-experimental-features \
+ $(extra_distcheck_flags)
SUBDIRS = po