summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimo Sorce <simo@redhat.com>2012-11-21 14:29:05 -0500
committerJakub Hrozek <jhrozek@redhat.com>2013-03-04 23:40:18 +0100
commit8bcabb97d988d1602882a1f036aac2eaf5e09234 (patch)
treebe185625c87100628b64b92aab72415f5d939e11 /Makefile.am
parent850ca620611f65115ee95e1d919be8443f95c14c (diff)
downloadsssd-8bcabb97d988d1602882a1f036aac2eaf5e09234.tar.gz
sssd-8bcabb97d988d1602882a1f036aac2eaf5e09234.tar.xz
sssd-8bcabb97d988d1602882a1f036aac2eaf5e09234.zip
Add SSSD specific error codes and definitions
This code adds a new range of error codes specific to SSSD, It also provides helper functions to print out error defintions like you can do with system error messages and the strerror() function. The sss_strerror() function can accept both the new sssd errors and system errno_t errors falling back to the system strerror() if the error code provide is not a valid SSSD error code.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4ff02b8e7..79e6e571c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -363,6 +363,7 @@ dist_noinst_HEADERS = \
src/util/crypto/sss_crypto.h \
src/util/dlinklist.h \
src/util/util.h \
+ src/util/util_errors.h \
src/util/strtonum.h \
src/util/sss_nss.h \
src/util/sss_ldap.h \
@@ -524,7 +525,8 @@ libsss_util_la_SOURCES = \
src/util/authtok.c \
src/util/sss_selinux.c \
src/util/domain_info_utils.c \
- src/util/util_lock.c
+ src/util/util_lock.c \
+ src/util/util_errors.c
libsss_util_la_LIBADD = \
$(SSSD_LIBS) \
$(UNICODE_LIBS) \