summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2013-05-11 10:53:12 +0200
committerJakub Hrozek <jhrozek@redhat.com>2013-05-30 13:46:10 +0200
commit777374243e15c53e7b0a7345e190c1018920be18 (patch)
tree4a343f9d58838d9eb155cdc68a218fac86de3b64 /Makefile.am
parent48cb64a1d6cf2ceff9e698c4626689cb53f7499c (diff)
downloadsssd-777374243e15c53e7b0a7345e190c1018920be18.tar.gz
sssd-777374243e15c53e7b0a7345e190c1018920be18.tar.xz
sssd-777374243e15c53e7b0a7345e190c1018920be18.zip
Allow flat name in the FQname format
https://fedorahosted.org/sssd/ticket/1648 Adds another expansion in the printf format that allows the user to use the domain flat name in the format.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 250f9b674..767e9b968 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -150,7 +150,8 @@ if HAVE_CMOCKA
test-find-uid \
test-io \
sss_nss_idmap-tests \
- dyndns-tests
+ dyndns-tests \
+ fqnames-tests
endif
check_PROGRAMS = \
@@ -1299,6 +1300,16 @@ dyndns_tests_LDADD = \
$(CMOCKA_LIBS) \
libsss_test_common.la \
libsss_util.la
+
+fqnames_tests_SOURCES = \
+ $(TEST_MOCK_OBJ) \
+ src/tests/cmocka/test_fqnames.c
+fqnames_tests_CFLAGS = \
+ $(AM_CFLAGS)
+fqnames_tests_LDADD = \
+ $(CMOCKA_LIBS) \
+ libsss_util.la
+
endif
noinst_PROGRAMS = pam_test_client