summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2013-04-09 17:40:40 +0200
committerJakub Hrozek <jhrozek@redhat.com>2013-05-03 20:25:46 +0200
commit5a4239490c7fb7d732180a9d40f27f0247c56631 (patch)
tree5d118934b4a922a1c549f1cc96b31c09ee60be64 /Makefile.am
parent04868f1573f4b26ef34610b6d7069172f93bd8ab (diff)
downloadsssd-5a4239490c7fb7d732180a9d40f27f0247c56631.tar.gz
sssd-5a4239490c7fb7d732180a9d40f27f0247c56631.tar.xz
sssd-5a4239490c7fb7d732180a9d40f27f0247c56631.zip
dyndns: new option dyndns_refresh_interval
This new options adds the possibility of updating the DNS entries periodically regardless if they have changed or not. This feature will be useful mainly in AD environments where the Windows clients periodically update their DNS records.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1bbfb01c3..5514fc020 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1283,10 +1283,13 @@ test_io_CFLAGS = \
test_io_LDADD = \
$(CMOCKA_LIBS)
+dyndns_tests_DEPENDENCIES = \
+ $(ldblib_LTLIBRARIES)
dyndns_tests_SOURCES = \
$(TEST_MOCK_OBJ) \
$(SSSD_RESOLV_OBJ) \
src/tests/common_tev.c \
+ src/tests/common_dom.c \
src/tests/cmocka/test_dyndns.c \
src/providers/data_provider_opts.c
dyndns_tests_CFLAGS = \