summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLukas Slebodnik <lslebodn@redhat.com>2013-03-08 14:26:42 +0100
committerSimo Sorce <simo@redhat.com>2013-03-13 14:41:33 -0400
commit22d381367c27910fe82f476a76b9f4ede555e35a (patch)
tree4c9c2d12bae688e4f94a9864f3069018bf171ca1 /Makefile.am
parent8359bf07a2e6c0181251ce8d5d9160dc57546c55 (diff)
downloadsssd-22d381367c27910fe82f476a76b9f4ede555e35a.tar.gz
sssd-22d381367c27910fe82f476a76b9f4ede555e35a.tar.xz
sssd-22d381367c27910fe82f476a76b9f4ede555e35a.zip
Reuse sss_open_cloexec at other places in code.
Functions open_cloexec and openat_cloexec were renamed with prefix "sss_" and moved to separete file. Replacing duplicated code of function sss_open_cloexec everywhere in the source code. https://fedorahosted.org/sssd/ticket/1794
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 0554a3670..e0756ea3a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -537,7 +537,8 @@ libsss_util_la_SOURCES = \
src/util/sss_selinux.c \
src/util/domain_info_utils.c \
src/util/util_lock.c \
- src/util/util_errors.c
+ src/util/util_errors.c \
+ src/util/io.c
libsss_util_la_LIBADD = \
$(SSSD_LIBS) \
$(UNICODE_LIBS) \
@@ -931,7 +932,8 @@ files_tests_CFLAGS = \
files_tests_LDADD = \
libsss_debug.la \
$(FILES_TESTS_LIBS) \
- libsss_test_common.la
+ libsss_test_common.la \
+ libsss_util.la
SSSD_RESOLV_TESTS_OBJ = \
$(SSSD_RESOLV_OBJ)