summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorTimo Aaltonen <timo.aaltonen@canonical.com>2012-12-01 11:45:10 +0200
committerJakub Hrozek <jhrozek@redhat.com>2012-12-14 17:45:18 +0100
commit72e8c6d2ffbe3140616aa68b21037299ef30c15b (patch)
tree3f6671fa9d98be494f16ce564dbdc849065bb4b9 /Makefile.am
parent2717aa2c83e1874bd8aad8ca467894a5bce60cbf (diff)
downloadsssd-72e8c6d2ffbe3140616aa68b21037299ef30c15b.tar.gz
sssd-72e8c6d2ffbe3140616aa68b21037299ef30c15b.tar.xz
sssd-72e8c6d2ffbe3140616aa68b21037299ef30c15b.zip
link sss_ssh_authorizedkeys and sss_ssh_knownhostsproxy with -lpthread
There used to be an overlinked dependency that's gone now, so to fix a build error add CLIENT_LIBS to sss_ssh_knownhostsproxy_LDFLAGS. v2: Fix sss_ssh_authorizedkeys linking as well.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e338c9c16..3145f4950 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -761,6 +761,7 @@ sss_ssh_authorizedkeys_SOURCES = \
sss_ssh_authorizedkeys_CFLAGS = $(AM_CFLAGS)
sss_ssh_authorizedkeys_LDADD = \
libsss_util.la
+sss_ssh_authorizedkeys_LDFLAGS = $(CLIENT_LIBS)
sss_ssh_knownhostsproxy_SOURCES = \
src/sss_client/common.c \
@@ -769,6 +770,7 @@ sss_ssh_knownhostsproxy_SOURCES = \
sss_ssh_knownhostsproxy_CFLAGS = $(AM_CFLAGS)
sss_ssh_knownhostsproxy_LDADD = \
libsss_util.la
+sss_ssh_knownhostsproxy_LDFLAGS = $(CLIENT_LIBS)
endif
#################