summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2012-10-18 16:34:35 +0200
committerJakub Hrozek <jhrozek@redhat.com>2012-11-05 00:14:05 +0100
commit2f13b3e3f29b7788b7613a275bd87dfc30d1b824 (patch)
tree67ed5e300f74b65b3e60fa7ef7c31f25477844a8 /Makefile.am
parent0331d26dc982df015568cd75a8c6a7ed1049854c (diff)
downloadsssd-2f13b3e3f29b7788b7613a275bd87dfc30d1b824.tar.gz
sssd-2f13b3e3f29b7788b7613a275bd87dfc30d1b824.tar.xz
sssd-2f13b3e3f29b7788b7613a275bd87dfc30d1b824.zip
krb5_child: send PAC to PAC responder
If the authenticated user comes from a different realm the service ticket which was returned during the validation of the TGT is used to extract the PAC which is send to the pac responder for evaluation.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index ee7e198f1..07dcbd219 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1443,7 +1443,8 @@ krb5_child_SOURCES = \
src/util/sss_krb5.c \
src/util/atomic_io.c \
src/util/util.c \
- src/util/signal.c
+ src/util/signal.c \
+ src/sss_client/common.c
krb5_child_CFLAGS = \
$(AM_CFLAGS) \
$(POPT_CFLAGS) \
@@ -1455,7 +1456,8 @@ krb5_child_LDADD = \
$(TEVENT_LIBS) \
$(POPT_LIBS) \
$(DHASH_LIBS) \
- $(KRB5_LIBS)
+ $(KRB5_LIBS) \
+ $(CLIENT_LIBS)
ldap_child_SOURCES = \
src/providers/ldap/ldap_child.c \