summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2012-03-26 21:41:28 -0400
committerStephen Gallagher <sgallagh@redhat.com>2012-07-06 11:44:45 -0400
commiteffcbdb12c7ef892f1fd92a745cb33a08ca4ba30 (patch)
tree5c3a38f819b64eb4f2c45575dc245a5b5db0bda9 /Makefile.am
parent42aeb975864c3c3ba971fd04c61a1aaf6e69905b (diff)
downloadsssd-effcbdb12c7ef892f1fd92a745cb33a08ca4ba30.tar.gz
sssd-effcbdb12c7ef892f1fd92a745cb33a08ca4ba30.tar.xz
sssd-effcbdb12c7ef892f1fd92a745cb33a08ca4ba30.zip
AD: Add AD identity provider
This new identity provider takes advantage of existing code for the LDAP provider, but provides sensible defaults for operating against an Active Directory 2008 R2 or later server.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 99565ee1b..c638f0223 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -117,6 +117,7 @@ if HAVE_CHECK
find_uid-tests \
auth-tests \
ipa_ldap_opt-tests \
+ ad_ldap_opt-tests \
simple_access-tests \
crypto-tests \
util-tests \
@@ -151,6 +152,7 @@ sssdlib_LTLIBRARIES = \
libsss_krb5.la \
libsss_proxy.la \
libsss_ipa.la \
+ libsss_ad.la \
libsss_simple.la
ldblib_LTLIBRARIES = \
@@ -931,6 +933,16 @@ ipa_ldap_opt_tests_LDADD = \
$(TALLOC_LIBS) \
libsss_test_common.la
+ad_ldap_opt_tests_SOURCES = \
+ src/tests/ad_ldap_opt-tests.c
+ad_ldap_opt_tests_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(CHECK_CFLAGS)
+ad_ldap_opt_tests_LDADD = \
+ $(CHECK_LIBS) \
+ $(TALLOC_LIBS) \
+ libsss_test_common.la
+
simple_access_tests_SOURCES = \
src/tests/simple_access-tests.c \
src/providers/simple/simple_access.c
@@ -1335,6 +1347,36 @@ libsss_ipa_la_SOURCES += src/providers/ipa/ipa_hostid.c
endif
+libsss_ad_la_SOURCES = \
+ src/providers/ad/ad_common.c \
+ src/providers/ad/ad_common.h \
+ src/providers/ad/ad_init.c \
+ src/providers/ad/ad_id.c \
+ src/providers/ad/ad_id.h \
+ src/providers/ad/ad_opts.h \
+ src/util/find_uid.c \
+ src/util/user_info_msg.c \
+ src/util/sss_krb5.c \
+ src/util/sss_ldap.c
+
+libsss_ad_la_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(LDAP_CFLAGS) \
+ $(DHASH_CFLAGS) \
+ $(KRB5_CFLAGS)
+libsss_ad_la_LIBADD = \
+ $(OPENLDAP_LIBS) \
+ $(DHASH_LIBS) \
+ $(KEYUTILS_LIBS) \
+ $(KRB5_LIBS) \
+ libsss_util.la \
+ libsss_ldap_common.la \
+ libsss_krb5_common.la \
+ libsss_idmap.la
+libsss_ad_la_LDFLAGS = \
+ -avoid-version \
+ -module
+
krb5_child_SOURCES = \
src/providers/krb5/krb5_become_user.c \
src/providers/krb5/krb5_child.c \