summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMartin Nagy <mnagy@redhat.com>2010-07-12 04:04:34 +0200
committerStephen Gallagher <sgallagh@redhat.com>2010-09-02 12:23:18 -0400
commit56d8d19ac9d857580a233d8264e851883b883c67 (patch)
tree8cb6e8236a24d230ea51f46fe22cd68fd4574e13 /Makefile.am
parent602fa2c3ef0d088b7b834e9d2ebb306d104a79ce (diff)
downloadsssd-56d8d19ac9d857580a233d8264e851883b883c67.tar.gz
sssd-56d8d19ac9d857580a233d8264e851883b883c67.tar.xz
sssd-56d8d19ac9d857580a233d8264e851883b883c67.zip
Make ldap bind asynchronous
Every ldap function that could possibly create a new connection is now wrapped in a tevent_req. If the connection is created, we will call the function again after the socket is ready for writing.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7482e811a..c485bc0dc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -331,6 +331,7 @@ dist_noinst_HEADERS = \
src/providers/krb5/krb5_common.h \
src/providers/krb5/krb5_utils.h \
src/providers/ldap/ldap_common.h \
+ src/providers/ldap/ldap_req_wrap.h \
src/providers/ldap/sdap.h \
src/providers/ldap/sdap_access.h \
src/providers/ldap/sdap_async.h \
@@ -731,6 +732,7 @@ libsss_ldap_la_SOURCES = \
src/providers/ldap/ldap_auth.c \
src/providers/ldap/ldap_init.c \
src/providers/ldap/ldap_common.c \
+ src/providers/ldap/ldap_req_wrap.c \
src/providers/ldap/sdap_async.c \
src/providers/ldap/sdap_async_accounts.c \
src/providers/ldap/sdap_async_connection.c \
@@ -811,6 +813,7 @@ libsss_ipa_la_SOURCES = \
src/providers/ldap/ldap_id_cleanup.c \
src/providers/ldap/ldap_auth.c \
src/providers/ldap/ldap_common.c \
+ src/providers/ldap/ldap_req_wrap.c \
src/providers/ldap/sdap_async.c \
src/providers/ldap/sdap_async_accounts.c \
src/providers/ldap/sdap_async_connection.c \