summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2011-08-30 10:51:19 -0400
committerStephen Gallagher <sgallagh@redhat.com>2011-10-26 10:29:39 -0400
commite97b2822ad260a1df04e9b5b26b93ea0fa1b9853 (patch)
tree2097c4dcd53a4311ea87e262a2e5429cdfa10d86 /Makefile.am
parent4396b4446acee09f5957ff63c4a86fdf854536df (diff)
downloadsssd-e97b2822ad260a1df04e9b5b26b93ea0fa1b9853.tar.gz
sssd-e97b2822ad260a1df04e9b5b26b93ea0fa1b9853.tar.xz
sssd-e97b2822ad260a1df04e9b5b26b93ea0fa1b9853.zip
Add option to specify the kerberos replay cache dir
Adds a configure option to set the distribution default as well as an sssd.conf option to override it. https://fedorahosted.org/sssd/ticket/980
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 44c9b7c42..6fa682456 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,6 +33,7 @@ initdir = @initdir@
logpath = @logpath@
pubconfpath = @pubconfpath@
pkgconfigdir = $(libdir)/pkgconfig
+krb5rcachedir = @krb5rcachedir@
AM_CFLAGS =
if WANT_AUX_INFO
@@ -1092,6 +1093,9 @@ install-data-hook:
rm $(DESTDIR)/$(nsslibdir)/libnss_sss.so.2 \
$(DESTDIR)/$(nsslibdir)/libnss_sss.so
mv $(DESTDIR)/$(nsslibdir)/libnss_sss.so.2.0.0 $(DESTDIR)/$(nsslibdir)/libnss_sss.so.2
+ if [ ! $(krb5rcachedir) = "__LIBKRB5_DEFAULTS__" ]; then \
+ mkdir -p $(DESTDIR)/$(krb5rcachedir) ; \
+ fi
uninstall-hook:
if [ -f $(abs_builddir)/src/config/.files ]; then \