summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2010-10-11 17:42:07 +0200
committerStephen Gallagher <sgallagh@redhat.com>2010-10-13 07:56:21 -0400
commitf0e068c0cee13eea020ab34304b7995849603dda (patch)
treea340d953d8a4401d6b216be5b00a32b9b4736ebc /Makefile.am
parentb306351547857d6e7d3db0b7c7ab9ded6e340c33 (diff)
downloadsssd-f0e068c0cee13eea020ab34304b7995849603dda.tar.gz
sssd-f0e068c0cee13eea020ab34304b7995849603dda.tar.xz
sssd-f0e068c0cee13eea020ab34304b7995849603dda.zip
Distribute XML sources instead of man-pages
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index ca99ccebf..e36a9511d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -966,13 +966,14 @@ DOCBOOK_XSLT = http://docbook.sourceforge.net/release/xsl/current/manpages/docbo
XMLLINT_FLAGS = --catalogs --postvalid --nonet --xinclude --noout
XSLTPROC_FLAGS = --catalogs --xinclude --nonet
-dist_man_MANS = \
+man_MANS = \
src/man/sss_useradd.8 src/man/sss_userdel.8 src/man/sss_usermod.8 \
src/man/sss_groupadd.8 src/man/sss_groupdel.8 src/man/sss_groupmod.8 \
src/man/sssd.8 src/man/sssd.conf.5 src/man/sssd-ldap.5 \
src/man/sssd-krb5.5 src/man/sssd-ipa.5 src/man/sssd-simple.5 \
src/man/sssd_krb5_locator_plugin.8 src/man/sss_groupshow.8 \
src/man/pam_sss.8 src/man/sss_obfuscate.8
+EXTRA_DIST += $(man_MANS:%=%.xml) $(wildcard src/man/include/*.xml)
SUFFIXES = .1.xml .1 .3.xml .3 .5.xml .5 .8.xml .8
.1.xml.1:
@@ -1081,7 +1082,7 @@ if BUILD_PYTHON_BINDINGS
cd $(srcdir)/src/config; $(PYTHON) setup.py build --build-base $(abs_builddir)/src/config clean --all
endif
rm -Rf doc
- rm -f $(dist_man_MANS)
+ rm -f $(man_MANS)
CLEANFILES = *.X */*.X */*/*.X