summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2010-08-29 22:15:06 +0200
committerStephen Gallagher <sgallagh@redhat.com>2010-09-08 09:36:22 -0400
commit88aeed9a31b734a92630d5e881c960c5f77ba0ce (patch)
tree516e1e785f1365873d8a036d8510e0492a8b6f87 /Makefile.am
parent530ba03ecabb472f17d5d1ab546aec9390492de1 (diff)
downloadsssd-88aeed9a31b734a92630d5e881c960c5f77ba0ce.tar.gz
sssd-88aeed9a31b734a92630d5e881c960c5f77ba0ce.tar.xz
sssd-88aeed9a31b734a92630d5e881c960c5f77ba0ce.zip
Deobfuscate password in back ends
When obfuscated password is used in config file, the LDAP backend converts it back to clear text and uses it to authenticate to the server.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index d6aef7fd6..f3f5a329c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -782,7 +782,8 @@ libsss_ldap_la_CFLAGS = \
libsss_ldap_la_LIBADD = \
$(OPENLDAP_LIBS) \
$(DHASH_LIBS) \
- $(KRB5_LIBS)
+ $(KRB5_LIBS) \
+ libsss_crypt.la
libsss_ldap_la_LDFLAGS = \
-version-info 1:0:0 \
-module
@@ -871,7 +872,8 @@ libsss_ipa_la_LIBADD = \
$(OPENLDAP_LIBS) \
$(DHASH_LIBS) \
$(KEYUTILS_LIBS) \
- $(KRB5_LIBS)
+ $(KRB5_LIBS) \
+ libsss_crypt.la
libsss_ipa_la_LDFLAGS = \
-version-info 1:0:0 \
-module