summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2010-01-18 09:37:44 -0500
committerStephen Gallagher <sgallagh@redhat.com>2010-01-21 15:02:15 -0500
commit1183d29d87c5c7439cf2364b7d7324d4a13b6e35 (patch)
treeda6a0adfc20c82f915c43c93ba0c83809bd296f8 /Makefile.am
parentee359fe1384507fed6c2274e7bfe81d288de4542 (diff)
downloadsssd-1183d29d87c5c7439cf2364b7d7324d4a13b6e35.tar.gz
sssd-1183d29d87c5c7439cf2364b7d7324d4a13b6e35.tar.xz
sssd-1183d29d87c5c7439cf2364b7d7324d4a13b6e35.zip
Add 'prerelease-srpms' target to Makefile
This target is available only if building from a git checkout. It will automatically populate the PRERELEASE_VERSION in version.m4 with the current datestamp and git commit id for creating an SRPM.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8801d08ce..b0f8959f1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -36,6 +36,14 @@ srpms: dist-gzip rpmroot
--define _source_filedigest_algorithm=1 \
-bs SPECS/sssd.spec
+if GIT_CHECKOUT
+prerelease-srpms:
+ cp $(srcdir)/version.m4 $(srcdir)/version.m4.orig
+ sed -e "s/m4_define(\[PRERELEASE_VERSION_NUMBER\], \[.*\])/m4_define(\[PRERELEASE_VERSION_NUMBER\], \[.`date +%Y%m%d`git`git log -1 --pretty=format:%h`\])/" < $(srcdir)/version.m4.orig > $(srcdir)/version.m4
+ $(MAKE) srpms
+ mv $(srcdir)/version.m4.orig $(srcdir)/version.m4
+endif
+
tests: all
for subdir in $(SUBDIRS); do \
$(MAKE) -C $$subdir $@; \