summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2010-11-19 14:16:10 -0500
committerStephen Gallagher <sgallagh@redhat.com>2010-11-24 10:09:16 -0500
commit4b0309363dbfb9a1409e082b3a84f17b53a751c1 (patch)
tree5eaa9c86090f9edcece17c836d65789baef0cb91 /Makefile.am
parentfa6c70fabb8dc2fab580a014cdcf1b0dd3e99554 (diff)
downloadsssd-4b0309363dbfb9a1409e082b3a84f17b53a751c1.tar.gz
sssd-4b0309363dbfb9a1409e082b3a84f17b53a751c1.tar.xz
sssd-4b0309363dbfb9a1409e082b3a84f17b53a751c1.zip
Print correct error messages for dp_err_to_string()
All errnum values passed into this function throughout the code are PAM error codes, but we were passing them through strerror() to print them, which is only meaningful for ERRNO error codes. This patch changes dp_err_to_string() to use pam_strerror() and renames it to dp_pam_err_to_string() for clarity. https://fedorahosted.org/sssd/ticket/636
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 102149a8c..6d91cf695 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -403,7 +403,8 @@ sssd_be_SOURCES = \
sssd_be_LDADD = $(SSSD_LIBS) $(CARES_LIBS)
sssd_be_LDFLAGS = \
-Wl,--version-script,$(srcdir)/src/providers/sssd_be.exports \
- -export-dynamic
+ -export-dynamic \
+ $(PAM_LIBS)
if BUILD_PYTHON_BINDINGS
sss_obfuscate_pythondir = $(sbindir)