summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLukas Slebodnik <lslebodn@redhat.com>2013-08-30 23:13:26 +0200
committerJakub Hrozek <jhrozek@redhat.com>2013-09-09 17:17:52 +0200
commit9917c138d9a270deb5820915384fbde751190c2a (patch)
treed36c7bd18c21dc8b42a4b76d83c085b1d5419257 /Makefile.am
parenta31df2979265339f71fe3e2d587c4176375b1eff (diff)
downloadsssd-9917c138d9a270deb5820915384fbde751190c2a.tar.gz
sssd-9917c138d9a270deb5820915384fbde751190c2a.tar.xz
sssd-9917c138d9a270deb5820915384fbde751190c2a.zip
AUTOTOOLS: More robust detection of inotify.
We checked only header file "sys/inotify" for detection whether inotify works. Some platforms do not have built in inotify, but contain library, which provides inotify-compatible interface. This patch adds more robust detection of inotify in configuration time and appends linker flags to Makefile if inotify is provided by library.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b6d2fd0d4..d21c5a717 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -630,6 +630,7 @@ sssd_SOURCES = \
src/util/nscd.c
sssd_LDADD = \
$(SSSD_LIBS) \
+ $(INOTIFY_LIBS) \
$(LIBNL_LIBS) \
$(KEYUTILS_LIBS) \
$(SSSD_INTERNAL_LTLIBS)