summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPavel Reichl <pavel.reichl@redhat.com>2013-11-14 21:52:26 +0000
committerJakub Hrozek <jhrozek@redhat.com>2013-12-02 04:58:01 +0100
commit94c85df2d7ded82f2939d8fe29821e4c78ff000d (patch)
tree924b49d4b42c3bdecc9348de82e2db9bd20d5da7 /Makefile.am
parent3cf1217a277d1103a8956e33fc0a8464227e2dd2 (diff)
downloadsssd-94c85df2d7ded82f2939d8fe29821e4c78ff000d.tar.gz
sssd-94c85df2d7ded82f2939d8fe29821e4c78ff000d.tar.xz
sssd-94c85df2d7ded82f2939d8fe29821e4c78ff000d.zip
SSSD: Unit test - sss_ldap_dn_in_search_bases
Unit test testing detection of the right domain when processing group with members from several domains Resolves: https://fedorahosted.org/sssd/ticket/2132
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am27
1 files changed, 26 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2ba1ec0fd..583ccdb49 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -151,7 +151,8 @@ if HAVE_CMOCKA
fqnames-tests \
test_sss_idmap \
test_utils \
- ad_access_filter_tests
+ ad_access_filter_tests \
+ test_search_bases
endif
check_PROGRAMS = \
@@ -1367,6 +1368,30 @@ test_utils_LDADD = \
$(SSSD_INTERNAL_LTLIBS) \
libsss_test_common.la
+test_search_bases_SOURCES = \
+ $(sssd_be_SOURCES) \
+ src/util/sss_ldap.c \
+ src/util/sss_krb5.c \
+ src/util/find_uid.c \
+ src/util/user_info_msg.c \
+ src/tests/cmocka/test_search_bases.c
+test_search_bases_CFLAGS = \
+ $(AM_CFLAGS) \
+ -DUNIT_TESTING
+test_search_bases_LDADD = \
+ $(PAM_LIBS) \
+ $(CMOCKA_LIBS) \
+ $(POPT_LIBS) \
+ $(SSSD_LIBS) \
+ $(CARES_LIBS) \
+ $(KRB5_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ $(SYSTEMD_LOGIN_LIBS) \
+ libsss_ldap_common.la \
+ libsss_idmap.la \
+ libsss_krb5_common.la \
+ libsss_test_common.la
+
ad_access_filter_tests_SOURCES = \
$(sssd_be_SOURCES) \
src/util/sss_ldap.c \