summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimo Sorce <simo@redhat.com>2013-09-05 11:52:08 -0400
committerSimo Sorce <simo@redhat.com>2013-09-09 15:11:45 -0400
commit36ccdecd053a9ad88dce86b8c84770dc2aa11d21 (patch)
treeeb3ece35f08a1a2aa4cd5535129fc4f784508771 /Makefile.am
parent9917c138d9a270deb5820915384fbde751190c2a (diff)
downloadsssd-36ccdecd053a9ad88dce86b8c84770dc2aa11d21.tar.gz
sssd-36ccdecd053a9ad88dce86b8c84770dc2aa11d21.tar.xz
sssd-36ccdecd053a9ad88dce86b8c84770dc2aa11d21.zip
tests: Add dlopen test to make sure modules works
This tests dlopens and resolves all symbols to make sure there are no missing symbols in our provider modules.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d21c5a717..150f53e72 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -114,6 +114,7 @@ endif
if HAVE_CHECK
non_interactive_check_based_tests = \
+ dlopen-tests \
sysdb-tests \
strtonum-tests \
resolv-tests \
@@ -890,6 +891,36 @@ if HAVE_CHECK
libsss_test_common_la_SOURCES += \
src/tests/common_check.c
+check_LTLIBRARIES = \
+ libdlopen_test_providers.la
+
+libdlopen_test_providers_la_SOURCES = \
+ $(sssd_be_SOURCES)
+libdlopen_test_providers_la_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(CHECK_CFLAGS) \
+ -DUNIT_TESTING
+libdlopen_test_providers_la_LIBADD = \
+ $(PAM_LIBS) \
+ $(SSSD_LIBS) \
+ $(CARES_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS)
+libdlopen_test_providers_la_LDFLAGS = \
+ -module \
+ -avoid-version \
+ -Wl,--version-script,$(srcdir)/src/providers/sssd_be.exports \
+ -rpath $(abs_top_builddir) \
+ -export-dynamic
+
+dlopen_tests_SOURCES = \
+ src/tests/dlopen-tests.c
+dlopen_tests_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(CHECK_CFLAGS)
+dlopen_tests_LDADD = \
+ $(LIBADD_DL) \
+ $(CHECK_LIBS)
+
sysdb_tests_DEPENDENCIES = \
$(ldblib_LTLIBRARIES)
sysdb_tests_SOURCES = \