summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2013-12-03 20:45:44 +0100
committerJakub Hrozek <jhrozek@redhat.com>2013-12-19 20:14:32 +0100
commit1dced7370e55be16154bbb649606f928765819d0 (patch)
treeefb26b696f5e6ce8d86c0a79a8c5856ac4968efd /Makefile.am
parent402af69c0bb7ea8b84e36f3567de6086042cb152 (diff)
downloadsssd-1dced7370e55be16154bbb649606f928765819d0.tar.gz
sssd-1dced7370e55be16154bbb649606f928765819d0.tar.xz
sssd-1dced7370e55be16154bbb649606f928765819d0.zip
AD: Add a utility function to create list of connections
ad_id.c and ad_access.c used the same block of code. With the upcoming option to disable GC lookups, we should unify the code in a function to avoid breaking one of the code paths. The same applies for the LDAP connection to the trusted AD DC. Includes a unit test.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 583ccdb49..da4070380 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -152,6 +152,7 @@ if HAVE_CMOCKA
test_sss_idmap \
test_utils \
ad_access_filter_tests \
+ ad_common_tests \
test_search_bases
endif
@@ -1398,6 +1399,7 @@ ad_access_filter_tests_SOURCES = \
src/util/sss_krb5.c \
src/util/find_uid.c \
src/util/user_info_msg.c \
+ src/providers/ad/ad_common.c \
src/tests/cmocka/test_ad_access_filter.c
ad_access_filter_tests_CFLAGS = \
$(AM_CFLAGS) \
@@ -1416,6 +1418,32 @@ ad_access_filter_tests_LDADD = \
libsss_krb5_common.la \
libsss_test_common.la
+ad_common_tests_SOURCES = \
+ $(sssd_be_SOURCES) \
+ src/util/sss_ldap.c \
+ src/util/sss_krb5.c \
+ src/util/find_uid.c \
+ src/util/user_info_msg.c \
+ src/tests/cmocka/test_ad_common.c
+ad_common_tests_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(SYSTEMD_LOGIN_CFLAGS) \
+ -DUNIT_TESTING
+ad_common_tests_LDFLAGS = \
+ -Wl,-wrap,sdap_set_sasl_options
+ad_common_tests_LDADD = \
+ $(PAM_LIBS) \
+ $(CMOCKA_LIBS) \
+ $(SSSD_LIBS) \
+ $(CARES_LIBS) \
+ $(KRB5_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ $(SYSTEMD_LOGIN_LIBS) \
+ libsss_ldap_common.la \
+ libsss_idmap.la \
+ libsss_krb5_common.la \
+ libsss_test_common.la
+
endif
noinst_PROGRAMS = pam_test_client