summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2011-08-30 10:51:19 -0400
committerStephen Gallagher <sgallagh@redhat.com>2011-09-02 09:58:29 -0400
commit9d3d669cc353475cfe023c2a20cc51fd07428b82 (patch)
tree400a35dcfc2703d22d91a31b3baacacfbd097743 /Makefile.am
parentb4378a86e669f3136c71c409c692302517b3474e (diff)
downloadsssd-9d3d669cc353475cfe023c2a20cc51fd07428b82.tar.gz
sssd-9d3d669cc353475cfe023c2a20cc51fd07428b82.tar.xz
sssd-9d3d669cc353475cfe023c2a20cc51fd07428b82.zip
Add option to specify the kerberos replay cache dir
Adds a configure option to set the distribution default as well as an sssd.conf option to override it. https://fedorahosted.org/sssd/ticket/980
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2cd08b8ec..c7bf8b09a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,6 +33,7 @@ initdir = @initdir@
logpath = @logpath@
pubconfpath = @pubconfpath@
pkgconfigdir = $(libdir)/pkgconfig
+krb5rcachedir = @krb5rcachedir@
AM_CFLAGS =
if WANT_AUX_INFO
@@ -1097,6 +1098,9 @@ install-data-hook:
rm $(DESTDIR)/$(nsslibdir)/libnss_sss.so.2 \
$(DESTDIR)/$(nsslibdir)/libnss_sss.so
mv $(DESTDIR)/$(nsslibdir)/libnss_sss.so.2.0.0 $(DESTDIR)/$(nsslibdir)/libnss_sss.so.2
+ if [ ! $(krb5rcachedir) = "__LIBKRB5_DEFAULTS__" ]; then \
+ mkdir -p $(DESTDIR)/$(krb5rcachedir) ; \
+ fi
uninstall-hook:
if [ -f $(abs_builddir)/src/config/.files ]; then \