summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Gallagher <sgallagh@redhat.com>2009-05-19 14:03:14 -0400
committerSimo Sorce <ssorce@redhat.com>2009-05-19 15:17:14 -0400
commit897060147ddea72ecc1e86c6b7b915ff1d462f71 (patch)
treea758e9d24c4c42a3c12b9b3b3c1251546928319a /Makefile.am
parent0a6de98efdfdd6108ca3394129d1eed873715df6 (diff)
downloadsssd-897060147ddea72ecc1e86c6b7b915ff1d462f71.tar.gz
sssd-897060147ddea72ecc1e86c6b7b915ff1d462f71.tar.xz
sssd-897060147ddea72ecc1e86c6b7b915ff1d462f71.zip
Fix RPM generation issues with sssd
Ensures that the common libraries build statically. Also ensures that the sssd.spec creates the SYSV init script with the appropriate permissions. Cleans up the useless rpmdist target that was obsolete. Adds the *.so.N.0.0 files to the RPM, as the .so and .so.N files were dangling symlinks.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 1 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 60d739e80..9030b10df 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,11 +14,7 @@ rpmroot:
mkdir -p $(RPMBUILD)/SPECS
mkdir -p $(RPMBUILD)/SRPMS
-rpmdistdir:
- mkdir -p dist/rpms
- mkdir -p dist/srpms
-
-rpms: dist-gzip rpmroot rpmdistdir
+rpms: dist-gzip rpmroot
cp $(builddir)/sssd.spec $(RPMBUILD)/SPECS
cp $(distdir).tar.gz $(RPMBUILD)/SOURCES
cd $(RPMBUILD); rpmbuild --define "_topdir $(RPMBUILD)" -ba SPECS/sssd.spec