summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2014-06-27 17:24:16 +0200
committerJakub Hrozek <jhrozek@redhat.com>2014-07-14 11:45:01 +0200
commit9f73110a498fc98fa644532f90b96b39cf9ef597 (patch)
treea7a1adde1ee0686783ee42e03c68e753a59223d2 /Makefile.am
parent489fb67c2cfc2103739556e0791ae5a63608d43f (diff)
downloadsssd-9f73110a498fc98fa644532f90b96b39cf9ef597.tar.gz
sssd-9f73110a498fc98fa644532f90b96b39cf9ef597.tar.xz
sssd-9f73110a498fc98fa644532f90b96b39cf9ef597.zip
TOOLS: New helper tool sss_signal
A minimal tool whose only purpose is to signal the monitor with SIGUSR2. The tool will be executed by the system bus in order to provide system activation, so it's packaged in libexec.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4da28f292..a27f83de9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -98,7 +98,9 @@ sssdlibexec_PROGRAMS = \
sssd_be \
krb5_child \
ldap_child \
- proxy_child
+ proxy_child \
+ sss_signal \
+ $(NULL)
if BUILD_SUDO
sssdlibexec_PROGRAMS += sssd_sudo
endif
@@ -933,6 +935,15 @@ sss_seed_LDADD = \
$(TOOLS_LIBS) \
$(SSSD_INTERNAL_LTLIBS)
+sss_signal_SOURCES = \
+ src/tools/sss_signal.c \
+ $(SSSD_TOOLS_OBJ) \
+ $(NULL)
+sss_signal_LDADD = \
+ $(TOOLS_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ $(NULL)
+
if BUILD_SUDO
sss_sudo_cli_SOURCES = \
src/sss_client/common.c \