summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2014-06-24 17:03:28 +0200
committerJakub Hrozek <jhrozek@redhat.com>2014-07-14 11:45:01 +0200
commit6cbd995992a91efb947ee6b62e67e19b8804bb06 (patch)
tree50543aaa31c3d3cbf768557047452dbde6758520 /Makefile.am
parent9f73110a498fc98fa644532f90b96b39cf9ef597 (diff)
downloadsssd-6cbd995992a91efb947ee6b62e67e19b8804bb06.tar.gz
sssd-6cbd995992a91efb947ee6b62e67e19b8804bb06.tar.xz
sssd-6cbd995992a91efb947ee6b62e67e19b8804bb06.zip
BUILD: Add the DBus service activation
The system bus has the ability to start services on demant. This patch adds the sysbus service activation file that, currently, only calls the sss_signal tool to signal the monitor.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a27f83de9..cf0385d8d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,6 +37,7 @@ sssdconfdir = $(sysconfdir)/sssd
sssddatadir = $(datadir)/sssd
sssdapiplugindir = $(sssddatadir)/sssd.api.d
dbuspolicydir = $(sysconfdir)/dbus-1/system.d
+dbusservicedir = $(datadir)/dbus-1/system-services
localedir = @localedir@
nsslibdir = @nsslibdir@
pamlibdir = @pammoddir@
@@ -808,6 +809,9 @@ sssd_ifp_LDADD = \
$(SSSD_INTERNAL_LTLIBS)
dist_dbuspolicy_DATA = \
src/responder/ifp/org.freedesktop.sssd.infopipe.conf
+dist_dbusservice_DATA = \
+ src/responder/ifp/org.freedesktop.sssd.infopipe.service
+
endif
sssd_be_SOURCES = \
@@ -2255,6 +2259,7 @@ installsssddirs::
$(DESTDIR)$(pluginpath) \
$(DESTDIR)$(libdir)/ldb \
$(DESTDIR)$(dbuspolicydir) \
+ $(DESTDIR)$(dbusservicedir) \
$(DESTDIR)$(pipepath)/private \
$(DESTDIR)$(sssdlibdir) \
$(DESTDIR)$(pkglibdir) \