summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2014-11-11 15:39:57 +0100
committerJakub Hrozek <jhrozek@redhat.com>2014-11-19 11:11:14 +0100
commitf716f3b0876edfd94be6f46f6390d7286fcf8443 (patch)
treebf9956d1954dfefe59271f7f43a0515ee6ebfbd0 /Makefile.am
parent29d7f951999d0c8aad33fd1d0cb25a9b50db693f (diff)
downloadsssd-f716f3b0876edfd94be6f46f6390d7286fcf8443.tar.gz
sssd-f716f3b0876edfd94be6f46f6390d7286fcf8443.tar.xz
sssd-f716f3b0876edfd94be6f46f6390d7286fcf8443.zip
BUILD: Make chown of files to sssd user non-fatal
In build environments, we can't assume the sssd user will be created prior to installing the package, so we can't chown the files. RPM will own the files instead in this case. Related: https://fedorahosted.org/sssd/ticket/2370 Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 6ce3a42f3..d58fcb950 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2884,12 +2884,12 @@ else
endif
if SSSD_USER
- chgrp $(SSSD_USER) $(sssdlibexecdir)/ldap_child
+ -chgrp $(SSSD_USER) $(sssdlibexecdir)/ldap_child
chmod 4750 $(sssdlibexecdir)/ldap_child
- chgrp $(SSSD_USER) $(sssdlibexecdir)/krb5_child
+ -chgrp $(SSSD_USER) $(sssdlibexecdir)/krb5_child
chmod 4750 $(sssdlibexecdir)/krb5_child
if BUILD_SEMANAGE
- chgrp $(SSSD_USER) $(sssdlibexecdir)/selinux_child
+ -chgrp $(SSSD_USER) $(sssdlibexecdir)/selinux_child
chmod 4750 $(sssdlibexecdir)/selinux_child
endif
endif