summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2014-10-01 14:47:09 +0200
committerJakub Hrozek <jhrozek@redhat.com>2014-10-30 11:12:33 +0100
commitf504126d3d54b5b1b5467b59616255ef4c46d1be (patch)
tree3ebe37ea8206242ab6a9f30a4d6d30df26f5181e /Makefile.am
parentbb0970825fa8702d8b5dea94d9fc97c1041db338 (diff)
downloadsssd-f504126d3d54b5b1b5467b59616255ef4c46d1be.tar.gz
sssd-f504126d3d54b5b1b5467b59616255ef4c46d1be.tar.xz
sssd-f504126d3d54b5b1b5467b59616255ef4c46d1be.zip
BUILD: Add a config option for sssd user, own private directories as the user
Adds a new configure-time option that lets you select the user to run SSSD as. The default is 'root' for backwards compatibility. The directories the deamon stores its private data at are also created as owned by this user during install time. Reviewed-by: Pavel Reichl <preichl@redhat.com> Reviewed-by: Simo Sorce <simo@redhat.com> (cherry picked from commit bc13c352ba9c2877f1e9bc62e55ad60fc000a55d)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am23
1 files changed, 17 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index b949c9c24..61bf5cf95 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -78,6 +78,14 @@ sudolibdir = @sudolibpath@
UNICODE_LIBS=@UNICODE_LIBS@
MKDIR_P = @MKDIR_P@
+INSTALL = @INSTALL@
+
+SSSD_USER = @SSSD_USER@
+
+INSTALL_USER_DIR_FLAGS = -d
+if SSSD_USER
+INSTALL_USER_DIR_FLAGS += -o $(SSSD_USER) -g $(SSSD_USER)
+endif
AM_CFLAGS =
if WANT_AUX_INFO
@@ -2740,24 +2748,27 @@ installsssddirs::
$(DESTDIR)$(bindir) \
$(DESTDIR)$(sbindir) \
$(DESTDIR)$(mandir) \
+ $(DESTDIR)$(pidpath) \
$(DESTDIR)$(pluginpath) \
$(DESTDIR)$(libdir)/ldb \
$(DESTDIR)$(dbuspolicydir) \
$(DESTDIR)$(dbusservicedir) \
- $(DESTDIR)$(pipepath)/private \
$(DESTDIR)$(sssdlibdir) \
$(DESTDIR)$(pkglibdir) \
- $(DESTDIR)$(sssdconfdir) \
$(DESTDIR)$(sssddatadir) \
+ $(DESTDIR)$(sudolibdir) \
+ $(DESTDIR)$(autofslibdir) \
+ $(NULL); \
+ $(INSTALL) $(INSTALL_USER_DIR_FLAGS) \
$(DESTDIR)$(dbpath) \
$(DESTDIR)$(mcpath) \
- $(DESTDIR)$(pidpath) \
- $(DESTDIR)$(logpath) \
+ $(DESTDIR)$(pipepath) \
+ $(DESTDIR)$(pipepath)/private \
$(DESTDIR)$(pubconfpath) \
$(DESTDIR)$(pubconfpath)/krb5.include.d \
$(DESTDIR)$(gpocachepath) \
- $(DESTDIR)$(sudolibdir) \
- $(DESTDIR)$(autofslibdir) \
+ $(DESTDIR)$(sssdconfdir) \
+ $(DESTDIR)$(logpath) \
$(NULL)
if HAVE_DOXYGEN