summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2014-12-01 12:04:25 +0100
committerJakub Hrozek <jhrozek@redhat.com>2014-12-03 11:02:32 +0100
commite00c2b5ac4963de9521599c88597b7fb97339d0e (patch)
treee1d5baad4a0639fe652faf03be222a6ba3c200f7 /Makefile.am
parentc9eaf8c1e02c155b7ca7ffb2b1edade8a23ce1ff (diff)
downloadsssd-e00c2b5ac4963de9521599c88597b7fb97339d0e.tar.gz
sssd-e00c2b5ac4963de9521599c88597b7fb97339d0e.tar.xz
sssd-e00c2b5ac4963de9521599c88597b7fb97339d0e.zip
TESTS: Basic child tests
The child_common.c module had no unit tests, yet we need to amend it. Reviewed-by: Sumit Bose <sbose@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a25354839..4543e64eb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -217,6 +217,7 @@ if HAVE_CMOCKA
test_be_ptask \
test_copy_ccache \
test_copy_keytab \
+ test_child_common \
$(NULL)
if BUILD_IFP
@@ -234,6 +235,7 @@ endif # HAVE_CMOCKA
check_PROGRAMS = \
stress-tests \
krb5-child-test \
+ test-child \
$(non_interactive_cmocka_based_tests) \
$(non_interactive_check_based_tests)
@@ -2132,6 +2134,29 @@ test_copy_keytab_LDADD = \
libsss_test_common.la \
$(NULL)
+test_child_SOURCES = \
+ src/tests/cmocka/test_child.c \
+ $(NULL)
+test_child_LDADD = \
+ $(POPT_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ $(NULL)
+
+test_child_common_SOURCES = \
+ src/tests/cmocka/test_child_common.c \
+ $(NULL)
+test_child_common_CFLAGS = \
+ $(AM_CFLAGS) \
+ -DCHILD_DIR=\"$(builddir)\" \
+ $(NULL)
+test_child_common_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(POPT_LIBS) \
+ $(TALLOC_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_test_common.la \
+ $(NULL)
+
endif # HAVE_CMOCKA
noinst_PROGRAMS = pam_test_client