summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2014-12-12 17:10:40 +0100
committerJakub Hrozek <jhrozek@redhat.com>2015-03-03 16:31:55 +0100
commitfe7fa93c69712637d4f6e050f654243e8c30c896 (patch)
treea35aea5ac708946072580660e58add956af1d7f9 /Makefile.am
parent75c2f20d1fc854e99f464098a23fe8cc3949fcb3 (diff)
downloadsssd-fe7fa93c69712637d4f6e050f654243e8c30c896.tar.gz
sssd-fe7fa93c69712637d4f6e050f654243e8c30c896.tar.xz
sssd-fe7fa93c69712637d4f6e050f654243e8c30c896.zip
FO: Use SRV TTL in fail over code
Resolves: https://fedorahosted.org/sssd/ticket/1884 Removes the hardcoded SRV TTL timeout and uses TTL from the DNS instead. Reviewed-by: Pavel Březina <pbrezina@redhat.com> (cherry picked from commit 8df69bbc58c2f4d3f0b34be9756d9ddf24b1db6d)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 29d148c4a..254930387 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -218,6 +218,7 @@ if HAVE_CMOCKA
test_copy_ccache \
test_copy_keytab \
test_child_common \
+ test_fo_srv \
$(NULL)
if HAVE_LIBRESOLV
@@ -2209,6 +2210,24 @@ test_resolv_fake_LDADD = \
$(NULL)
endif # HAVE_LIBRESOLV
+test_fo_srv_SOURCES = \
+ src/tests/cmocka/test_fo_srv.c \
+ src/providers/fail_over.c \
+ src/providers/fail_over_srv.c \
+ $(NULL)
+test_fo_srv_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(NULL)
+test_fo_srv_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(POPT_LIBS) \
+ $(TALLOC_LIBS) \
+ $(CARES_LIBS) \
+ $(DHASH_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_test_common.la \
+ $(NULL)
+
endif # HAVE_CMOCKA
noinst_PROGRAMS = pam_test_client