summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPavel Reichl <preichl@redhat.com>2014-10-30 10:13:54 +0000
committerJakub Hrozek <jhrozek@redhat.com>2014-12-02 22:21:11 +0100
commiteba68b29d934e6ba3879947ab002f1b0a2c24496 (patch)
treef4aa5de9910f9b802e2574aa3e8c6c2cc7be6434 /Makefile.am
parent939d44cef4d202a7ef88250e90c22f6c6a3acc50 (diff)
downloadsssd-eba68b29d934e6ba3879947ab002f1b0a2c24496.tar.gz
sssd-eba68b29d934e6ba3879947ab002f1b0a2c24496.tar.xz
sssd-eba68b29d934e6ba3879947ab002f1b0a2c24496.zip
BUILD: restrict perms. when installing from source
Resolves: https://fedorahosted.org/sssd/ticket/2467 Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a903e350e..a25354839 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2887,6 +2887,12 @@ if SSSD_USER
-chown $(SSSD_USER):$(SSSD_USER) \
$(SSSD_USER_DIRS)
endif
+ $(INSTALL) -d -m 0700 $(DESTDIR)$(dbpath) $(DESTDIR)$(logpath) \
+ $(DESTDIR)$(pipepath)/private
+ $(INSTALL) -d -m 0755 $(DESTDIR)$(mcpath) $(DESTDIR)$(pipepath) \
+ $(DESTDIR)$(pubconfpath) \
+ $(DESTDIR)$(pubconfpath)/krb5.include.d $(DESTDIR)$(gpocachepath)
+ $(INSTALL) -d -m 0711 $(DESTDIR)$(sssdconfdir)
if HAVE_DOXYGEN
docs: