summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2014-12-03 17:00:25 +0100
committerJakub Hrozek <jhrozek@redhat.com>2014-12-04 11:39:38 +0100
commit9f521c61c17cecd9625ebc1b33c666fa3488622c (patch)
tree53f9e0b693a1b7b3636f13cc524af8163d1e2e52 /Makefile.am
parent714446cfe8f7f577e8c546cfc1b4cf7d425b5f7a (diff)
downloadsssd-9f521c61c17cecd9625ebc1b33c666fa3488622c.tar.gz
sssd-9f521c61c17cecd9625ebc1b33c666fa3488622c.tar.xz
sssd-9f521c61c17cecd9625ebc1b33c666fa3488622c.zip
TESTS: Build test_child even without cmocka
Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4543e64eb..55c1c70bf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -235,10 +235,13 @@ endif # HAVE_CMOCKA
check_PROGRAMS = \
stress-tests \
krb5-child-test \
- test-child \
$(non_interactive_cmocka_based_tests) \
$(non_interactive_check_based_tests)
+if HAVE_CMOCKA
+check_PROGRAMS += test-child
+endif # HAVE_CMOCKA
+
PYTHON_TESTS =
if BUILD_PYTHON_BINDINGS