summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2014-11-17 17:39:38 +0100
committerJakub Hrozek <jhrozek@redhat.com>2014-12-02 20:02:14 +0100
commit802385896dc1c4e7b8bbd40dcfe3cd131f68e696 (patch)
tree2e0ac84c39446ef2e1752b4ce732635b6d0e8263 /Makefile.am
parente36226da4d7d0e8000a25ab310383318e00d58d1 (diff)
downloadsssd-802385896dc1c4e7b8bbd40dcfe3cd131f68e696.tar.gz
sssd-802385896dc1c4e7b8bbd40dcfe3cd131f68e696.tar.xz
sssd-802385896dc1c4e7b8bbd40dcfe3cd131f68e696.zip
krb5: add copy_ccache_into_memory()
Reviewed-by: Jakub Hrozek <jhrozek@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b9c25f906..54527223a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -215,6 +215,7 @@ if HAVE_CMOCKA
sdap-tests \
test_sysdb_views \
test_be_ptask \
+ test_copy_ccache \
$(NULL)
if BUILD_IFP
@@ -2096,6 +2097,23 @@ test_be_ptask_LDADD = \
libsss_test_common.la \
$(NULL)
+test_copy_ccache_SOURCES = \
+ src/tests/cmocka/test_copy_ccache.c \
+ src/providers/krb5/krb5_ccache.c \
+ src/util/sss_krb5.c \
+ $(NULL)
+test_copy_ccache_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(NULL)
+test_copy_ccache_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(POPT_LIBS) \
+ $(TALLOC_LIBS) \
+ $(KRB5_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_test_common.la \
+ $(NULL)
+
endif # HAVE_CMOCKA
noinst_PROGRAMS = pam_test_client