summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLukas Slebodnik <lslebodn@redhat.com>2014-12-03 14:06:18 +0100
committerJakub Hrozek <jhrozek@redhat.com>2014-12-08 22:47:13 +0100
commit4d9db278db1197ae84fecb8f269e2de368a6be2a (patch)
treeafac88b15603acc71b66a06398b8e9c93524266a /Makefile.am
parent5bb0c0596765dd5dd1973b7fc2d1e830bca3e345 (diff)
downloadsssd-4d9db278db1197ae84fecb8f269e2de368a6be2a.tar.gz
sssd-4d9db278db1197ae84fecb8f269e2de368a6be2a.tar.xz
sssd-4d9db278db1197ae84fecb8f269e2de368a6be2a.zip
MAKE: Fix linking of test_child_common
Compilation of test_child_common failed with linker flag --as-needned due to cyclic dependencies between libsss_child.so and libsss_util.so CCLD test_child_common ./.libs/libsss_child.so: undefined reference to `sss_hash_create' ./.libs/libsss_child.so: undefined reference to `hash_lookup' ./.libs/libsss_child.so: undefined reference to `BlockSignals' ./.libs/libsss_child.so: undefined reference to `hash_delete' ./.libs/libsss_child.so: undefined reference to `hash_enter' ./.libs/libsss_child.so: undefined reference to `hash_error_string' ./.libs/libsss_child.so: undefined reference to `sss_atomic_io_s' ./.libs/libsss_child.so: undefined reference to `sss_strerror' collect2: error: ld returned 1 exit status This patch is temporary workaround. Reviewed-by: Jakub Hrozek <jhrozek@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e61531ade..80564d604 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2147,6 +2147,11 @@ dummy_child_LDADD = \
test_child_common_SOURCES = \
src/tests/cmocka/test_child_common.c \
+ src/util/child_common.c \
+ src/util/signal.c \
+ src/util/atomic_io.c \
+ src/util/util_errors.c \
+ src/util/util.c \
$(NULL)
test_child_common_CFLAGS = \
$(AM_CFLAGS) \
@@ -2156,7 +2161,8 @@ test_child_common_LDADD = \
$(CMOCKA_LIBS) \
$(POPT_LIBS) \
$(TALLOC_LIBS) \
- $(SSSD_INTERNAL_LTLIBS) \
+ $(DHASH_LIBS) \
+ libsss_debug.la \
libsss_test_common.la \
$(NULL)