summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2014-12-12 17:10:25 +0100
committerJakub Hrozek <jhrozek@redhat.com>2015-02-11 11:10:40 +0100
commit3149069126599133a8fe0c66734df6deb3907dfb (patch)
treecc76246f3e6a75cd0b4a16c2225020e680a6e0b4 /Makefile.am
parent07d69e93a2d2ba68c2fe67d8fb5de18cf69ba797 (diff)
downloadsssd-3149069126599133a8fe0c66734df6deb3907dfb.tar.gz
sssd-3149069126599133a8fe0c66734df6deb3907dfb.tar.xz
sssd-3149069126599133a8fe0c66734df6deb3907dfb.zip
RESOLV: Add an internal function to read TTL from a DNS packet
Related: https://fedorahosted.org/sssd/ticket/1884 Adds an internal resolver function that reads the TTL for SRV records as specified by RFC-2181. Several internal c-ares definitions are used until c-ares contains a function that exposes all this information via a parsing function. Reviewed-by: Pavel Březina <pbrezina@redhat.com> (cherry picked from commit bf54fbed126ec3d459af40ea370ffadacd31c76d)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index fcfaf026c..05b372330 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -220,6 +220,10 @@ if HAVE_CMOCKA
test_child_common \
$(NULL)
+if HAVE_LIBRESOLV
+non_interactive_cmocka_based_tests += test_resolv_fake
+endif # HAVE_LIBRESOLV
+
if BUILD_IFP
non_interactive_cmocka_based_tests += ifp_tests
endif # BUILD_IFP
@@ -2180,6 +2184,29 @@ test_child_common_LDADD = \
libsss_test_common.la \
$(NULL)
+if HAVE_LIBRESOLV
+test_resolv_fake_SOURCES = \
+ src/tests/cmocka/test_resolv_fake.c \
+ src/resolv/async_resolv.c \
+ $(NULL)
+test_resolv_fake_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(NULL)
+test_resolv_fake_LDFLAGS = \
+ -Wl,-wrap,ares_query \
+ $(NULL)
+test_resolv_fake_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(POPT_LIBS) \
+ $(TALLOC_LIBS) \
+ $(CARES_LIBS) \
+ $(DHASH_LIBS) \
+ $(RESOLV_LIBS) \
+ libsss_debug.la \
+ libsss_test_common.la \
+ $(NULL)
+endif # HAVE_LIBRESOLV
+
endif # HAVE_CMOCKA
noinst_PROGRAMS = pam_test_client