summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2015-02-23 11:06:25 +0100
committerJakub Hrozek <jhrozek@redhat.com>2015-02-25 09:16:46 +0100
commitbdc2aced1185c4ee36921fa01b8dc01789a63900 (patch)
tree0a7b6ddb16e31b0c167f695cdde5f90c41db8ede /Makefile.am
parent889706cbc739358c2a0aac2ba6bc054fdc8e048b (diff)
downloadsssd-bdc2aced1185c4ee36921fa01b8dc01789a63900.tar.gz
sssd-bdc2aced1185c4ee36921fa01b8dc01789a63900.tar.xz
sssd-bdc2aced1185c4ee36921fa01b8dc01789a63900.zip
PAM: print the pam status as string, too
On several places, let's add a pam_strerror() call so that it's easier to debug user problems. Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com> Signed-off-by: Lukas Slebodnik <lslebodn@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ee23a4111..8f0ce4be9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1005,7 +1005,9 @@ sssd_pam_LDADD = \
$(TDB_LIBS) \
$(SSSD_LIBS) \
$(SELINUX_LIBS) \
- $(SSSD_INTERNAL_LTLIBS)
+ $(PAM_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ $(NULL)
if BUILD_SUDO
sssd_sudo_SOURCES = \