summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2015-05-29 13:59:05 +0200
committerJakub Hrozek <jhrozek@redhat.com>2015-06-14 21:47:19 +0200
commitb1a822a16e3ef97e31d167f9e97efec06fc121dc (patch)
tree99456fbaf7b328eb42d8c4bd38c04116587c4199 /Makefile.am
parent298e22fc97a99994e025c0d507737d88fe6fafef (diff)
downloadsssd-b1a822a16e3ef97e31d167f9e97efec06fc121dc.tar.gz
sssd-b1a822a16e3ef97e31d167f9e97efec06fc121dc.tar.xz
sssd-b1a822a16e3ef97e31d167f9e97efec06fc121dc.zip
TESTS: Split off keytab creation into a common module
This change will make the keytab creating reusable by other tests. Reviewed-by: Sumit Bose <sbose@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 816f18e4c..6912fa971 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -619,6 +619,7 @@ dist_noinst_HEADERS = \
src/tests/cmocka/common_mock_resp.h \
src/tests/cmocka/common_mock_sdap.h \
src/tests/cmocka/common_mock_sysdb_objects.h \
+ src/tests/cmocka/common_mock_krb5.h \
src/tests/cmocka/test_expire_common.h \
src/sss_client/pam_message.h \
src/sss_client/ssh/sss_ssh_client.h \
@@ -2300,6 +2301,7 @@ test_copy_ccache_LDADD = \
$(NULL)
test_copy_keytab_SOURCES = \
+ src/tests/cmocka/common_mock_krb5.c \
src/tests/cmocka/test_copy_keytab.c \
src/providers/krb5/krb5_keytab.c \
src/util/sss_krb5.c \