summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2013-10-23 14:39:55 +0200
committerJakub Hrozek <jhrozek@redhat.com>2013-10-25 15:31:15 +0200
commit939246537b0b9a4af6862c513d3919501ad57d92 (patch)
treebd624f78883af27fd9cbe32fcdf1c231cae98c26 /Makefile.am
parent648d3ec563fafea7d7daf88b46e28ce0d43b3935 (diff)
downloadsssd-939246537b0b9a4af6862c513d3919501ad57d92.tar.gz
sssd-939246537b0b9a4af6862c513d3919501ad57d92.tar.xz
sssd-939246537b0b9a4af6862c513d3919501ad57d92.zip
find_subdomain_by_sid: skip domains with missing domain_id
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 98a298eae..1b35d0586 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -152,7 +152,8 @@ if HAVE_CMOCKA
sss_nss_idmap-tests \
dyndns-tests \
fqnames-tests \
- test_sss_idmap
+ test_sss_idmap \
+ test_utils
endif
check_PROGRAMS = \
@@ -1379,6 +1380,15 @@ test_sss_idmap_LDADD = \
$(SSSD_INTERNAL_LTLIBS) \
libsss_test_common.la
+test_utils_SOURCES = \
+ $(TEST_MOCK_OBJ) \
+ src/tests/cmocka/test_utils.c
+test_utils_CFLAGS = \
+ $(AM_CFLAGS)
+test_utils_LDADD = \
+ $(CMOCKA_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_test_common.la
endif
noinst_PROGRAMS = pam_test_client