summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2015-09-04 18:45:45 +0200
committerJakub Hrozek <jhrozek@redhat.com>2015-09-22 13:46:02 +0200
commitfb83de0699b16e7d8eca803305e2112795807b4c (patch)
tree8becc37d1ca208ee3ee60dd274d421fb4344e6a1 /Makefile.am
parentcf66c53e46fad46f47489f43265c58004e0e39d4 (diff)
downloadsssd-fb83de0699b16e7d8eca803305e2112795807b4c.tar.gz
sssd-fb83de0699b16e7d8eca803305e2112795807b4c.tar.xz
sssd-fb83de0699b16e7d8eca803305e2112795807b4c.zip
LDAP: Filter out multiple entries when searching overlapping domains
In case domain overlap, we might download multiple objects. To avoid saving them all, we attempt to filter out the objects from foreign domains. We can only do this optimization for non-wildcard lookups. Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 583ba9440..2d704fd39 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1634,6 +1634,7 @@ ipa_ldap_opt_tests_SOURCES = \
src/providers/data_provider_opts.c \
src/providers/ldap/sdap.c \
src/providers/ldap/sdap_range.c \
+ src/providers/ldap/sdap_domain.c \
src/util/sss_ldap.c \
src/tests/ipa_ldap_opt-tests.c
ipa_ldap_opt_tests_CFLAGS = \
@@ -1642,6 +1643,7 @@ ipa_ldap_opt_tests_CFLAGS = \
ipa_ldap_opt_tests_LDADD = \
$(CHECK_LIBS) \
$(TALLOC_LIBS) \
+ $(LDB_LIBS) \
$(SSSD_INTERNAL_LTLIBS) \
$(OPENLDAP_LIBS) \
libsss_test_common.la
@@ -2225,6 +2227,7 @@ dp_opt_tests_LDADD = \
sdap_tests_SOURCES = \
src/providers/data_provider_opts.c \
+ src/providers/ldap/sdap_domain.c \
src/providers/ldap/sdap.c \
src/providers/ldap/sdap_range.c \
src/util/sss_ldap.c \
@@ -2246,6 +2249,7 @@ sdap_tests_LDFLAGS = \
sdap_tests_LDADD = \
$(CMOCKA_LIBS) \
$(TALLOC_LIBS) \
+ $(LDB_LIBS) \
$(POPT_LIBS) \
$(SSSD_INTERNAL_LTLIBS) \
$(SSS_CRYPT_LIBS) \