summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLukas Slebodnik <lslebodn@redhat.com>2015-09-10 13:34:14 +0200
committerJakub Hrozek <jhrozek@redhat.com>2015-09-18 13:31:54 +0200
commit50c9d542e8bf641412debaa82a4dcf67ddb72258 (patch)
tree25e4501760b51b2dca676e137f65a004a3bc576a /Makefile.am
parentd71cd46ede9c57e3947c86c61306a9caddce242c (diff)
downloadsssd-50c9d542e8bf641412debaa82a4dcf67ddb72258.tar.gz
sssd-50c9d542e8bf641412debaa82a4dcf67ddb72258.tar.xz
sssd-50c9d542e8bf641412debaa82a4dcf67ddb72258.zip
tests: Use unique name for TEST_PATH
We had a cases in patch where two tests were using the same TEST_PATH and therefore they were stepping each other to the same files which caused failures. These failures are not easy to reproduce. This patch uses macro BASE_FILE_STEM for unique name. It should prevent copy&paste problem resulting to intermittent failures. @see also https://www.gnu.org/software/make/manual/html_node/Automatic-Variables.html Reviewed-by: Jakub Hrozek <jhrozek@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index dc0670a5c..ff3434301 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -433,7 +433,9 @@ AM_CPPFLAGS = \
-DSSS_SUDO_SOCKET_NAME=\"$(pipepath)/sudo\" \
-DSSS_AUTOFS_SOCKET_NAME=\"$(pipepath)/autofs\" \
-DSSS_SSH_SOCKET_NAME=\"$(pipepath)/ssh\" \
- -DLOCALEDIR=\"$(localedir)\"
+ -DLOCALEDIR=\"$(localedir)\" \
+ -DBASE_FILE_STEM=\"$(*F)\" \
+ $(NULL)
EXTRA_DIST =