summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2014-07-27 14:44:24 +0200
committerJakub Hrozek <jhrozek@redhat.com>2014-10-07 13:48:05 +0200
commit533e8a1af98c1f6119e7535989acdc72cf652fa6 (patch)
tree948e7e14520d3e87cdcf5004b191fd2a480deb94 /Makefile.am
parent7538fcd93688bed5eeea46cffbacf1826be7d59b (diff)
downloadsssd-533e8a1af98c1f6119e7535989acdc72cf652fa6.tar.gz
sssd-533e8a1af98c1f6119e7535989acdc72cf652fa6.tar.xz
sssd-533e8a1af98c1f6119e7535989acdc72cf652fa6.zip
TESTS: Add a test to change user IDs
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ac3f26cad..91cda02ca 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,6 +19,16 @@ if HAVE_MANPAGES
SUBDIRS += src/man
endif
+# The cwrap tests require the wrapper libraries and are written
+# using cmocka
+if HAVE_CMOCKA
+if HAVE_NSS_WRAPPER
+if HAVE_UID_WRAPPER
+SUBDIRS += src/tests/cwrap
+endif # HAVE_UID_WRAPPER
+endif # HAVE_NSS_WRAPPER
+endif # HAVE_CMOCKA
+
# Some old versions of automake don't define builddir
builddir ?= .
@@ -2829,6 +2839,7 @@ endif
CLEANFILES = *.X */*.X */*/*.X
tests: all $(check_PROGRAMS)
+ (cd src/tests/cwrap && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
# RPM-related tasks