summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNikolai Kondrashov <Nikolai.Kondrashov@redhat.com>2014-06-16 19:39:25 +0300
committerJakub Hrozek <jhrozek@redhat.com>2014-06-19 17:53:24 +0200
commitc6e39e15178675d0779e0ae855245774a09b4eb5 (patch)
tree749cbdd9909f0212ffa2fa64045dcbd3b98f9cb7 /Makefile.am
parentba99aa00a305d298f65379e3add7536553c82455 (diff)
downloadsssd-c6e39e15178675d0779e0ae855245774a09b4eb5.tar.gz
sssd-c6e39e15178675d0779e0ae855245774a09b4eb5.tar.xz
sssd-c6e39e15178675d0779e0ae855245774a09b4eb5.zip
build: Switch back to DISTCHECK_CONFIGURE_FLAGS
Switch back to using DISTCHECK_CONFIGURE_FLAGS instead of the AM_-version in Makefile.am, as the latter is not supported by Automake version in RHEL6. Instead, use a special variable AUX_DISTCHECK_CONFIGURE_FLAGS to augment distcheck target configure flags from the command line. Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index c256c3c8d..91142b396 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,10 +7,11 @@ if WITH_JOURNALD
extra_distcheck_flags += --with-syslog=journald
endif
-AM_DISTCHECK_CONFIGURE_FLAGS = --with-ldb-lib-dir="$$dc_install_base"/lib/ldb \
- --disable-dbus-tests \
- --enable-all-experimental-features \
- $(extra_distcheck_flags)
+DISTCHECK_CONFIGURE_FLAGS = --with-ldb-lib-dir="$$dc_install_base"/lib/ldb \
+ --disable-dbus-tests \
+ --enable-all-experimental-features \
+ $(extra_distcheck_flags) \
+ $(AUX_DISTCHECK_CONFIGURE_FLAGS)
SUBDIRS = po