summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2014-11-06 13:13:27 +0100
committerJakub Hrozek <jhrozek@redhat.com>2014-11-20 10:52:38 +0100
commit8eb981dd8bc85aee7a913c6f0096ad47f3382339 (patch)
tree5a97040329b13209dbea291ec2d9b827428c8029 /Makefile.am
parent907a7c626db407d19d4cae85c2db7d3561120349 (diff)
downloadsssd-8eb981dd8bc85aee7a913c6f0096ad47f3382339.tar.gz
sssd-8eb981dd8bc85aee7a913c6f0096ad47f3382339.tar.xz
sssd-8eb981dd8bc85aee7a913c6f0096ad47f3382339.zip
ipa: add split_ipa_anchor()
This call extracts the domain and the UUID part from an IPA override anchor. Related to https://fedorahosted.org/sssd/ticket/2481 Reviewed-by: Jakub Hrozek <jhrozek@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 156ef3c4e..53ace65b9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2064,6 +2064,7 @@ endif # BUILD_IFP
test_sysdb_views_SOURCES = \
src/tests/cmocka/test_sysdb_views.c \
+ src/providers/ipa/ipa_utils.c \
$(NULL)
test_sysdb_views_CFLAGS = \
$(AM_CFLAGS) \
@@ -2387,6 +2388,7 @@ libsss_ipa_la_SOURCES = \
src/providers/ipa/ipa_subdomains_id.c \
src/providers/ipa/ipa_subdomains_ext_groups.c \
src/providers/ipa/ipa_views.c \
+ src/providers/ipa/ipa_utils.c \
src/providers/ipa/ipa_s2n_exop.c \
src/providers/ipa/ipa_hbac_hosts.c \
src/providers/ipa/ipa_hbac_private.h \