summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2014-03-11 17:39:31 +0100
committerJakub Hrozek <jhrozek@redhat.com>2014-07-23 21:28:31 +0200
commit8a8618717c99b7331125fa736b45d9155da797d3 (patch)
tree8127472cbdf092d4ae417a03589324d18e48f41e /Makefile.am
parente3c994b7b779e6d6d6d125ee28d30bd139590f49 (diff)
downloadsssd-8a8618717c99b7331125fa736b45d9155da797d3.tar.gz
sssd-8a8618717c99b7331125fa736b45d9155da797d3.tar.xz
sssd-8a8618717c99b7331125fa736b45d9155da797d3.zip
Only check GID if ID-mapping
Reviewed-by: Sumit Bose <sbose@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index e3592868c..783a8922e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1740,15 +1740,20 @@ fqnames_tests_LDADD = \
nestedgroups_tests_SOURCES = \
$(TEST_MOCK_OBJ) \
$(TEST_MOCK_PROVIDER_OBJ) \
+ src/providers/ldap/sdap_idmap.c \
src/tests/cmocka/test_nested_groups.c \
- src/providers/ldap/sdap_async_nested_groups.c
+ src/providers/ldap/sdap_async_nested_groups.c \
+ $(NULL)
nestedgroups_tests_CFLAGS = \
- $(AM_CFLAGS)
+ $(AM_CFLAGS) \
+ $(NULL)
nestedgroups_tests_LDADD = \
$(CMOCKA_LIBS) \
$(SSSD_LIBS) \
$(SSSD_INTERNAL_LTLIBS) \
- libsss_test_common.la
+ libsss_idmap.la \
+ libsss_test_common.la \
+ $(NULL)
test_sss_idmap_SOURCES = \
src/tests/cmocka/test_sss_idmap.c