summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSumit Bose <sbose@redhat.com>2014-07-16 21:43:30 +0200
committerJakub Hrozek <jhrozek@redhat.com>2014-09-02 10:39:24 +0200
commit8a5e793a0576250da80371e53aa3e7eba15cdb63 (patch)
tree5e0533d309ba63b9f317c57671430e4a79ca7953 /Makefile.am
parent8cfd1e0d696a573a92ef011a64317b9054f5c45f (diff)
downloadsssd-8a5e793a0576250da80371e53aa3e7eba15cdb63.tar.gz
sssd-8a5e793a0576250da80371e53aa3e7eba15cdb63.tar.xz
sssd-8a5e793a0576250da80371e53aa3e7eba15cdb63.zip
Add conditional build for MIT Kerberos localauth plugin
This patch adds everything what is needed to build the MIT Kerberos localauth plugin if the used version of MIT Kerberos supports it. It does not implement the plugin. Reviewed-by: Jakub Hrozek <jhrozek@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4c3dc35d2..64c017ea0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,6 +35,9 @@ ldblibdir = @ldblibdir@
if BUILD_KRB5_LOCATOR_PLUGIN
krb5plugindir = @krb5pluginpath@
endif
+if BUILD_KRB5_LOCALAUTH_PLUGIN
+krb5localauth_plugindir = @appmodpath@
+endif
if BUILD_PAC_RESPONDER
krb5authdata_plugindir = @krb5authdatapluginpath@
endif
@@ -250,6 +253,11 @@ krb5plugin_LTLIBRARIES = \
sssd_krb5_locator_plugin.la
endif
+if BUILD_KRB5_LOCALAUTH_PLUGIN
+krb5localauth_plugin_LTLIBRARIES = \
+ sssd_krb5_localauth_plugin.la
+endif
+
if BUILD_PAC_RESPONDER
krb5authdata_plugin_LTLIBRARIES = \
sssd_pac_plugin.la
@@ -2475,6 +2483,17 @@ sssd_krb5_locator_plugin_la_LDFLAGS = \
-module
endif
+if BUILD_KRB5_LOCALAUTH_PLUGIN
+sssd_krb5_localauth_plugin_la_SOURCES = \
+ src/krb5_plugin/sssd_krb5_localauth_plugin.c
+sssd_krb5_localauth_plugin_la_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(KRB5_CFLAGS)
+sssd_krb5_localauth_plugin_la_LDFLAGS = \
+ -avoid-version \
+ -module
+endif
+
sssd_pac_plugin_la_SOURCES = \
src/sss_client/sssd_pac.c \
src/sss_client/common.c \