summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLukas Slebodnik <lslebodn@redhat.com>2014-07-09 12:47:55 +0200
committerJakub Hrozek <jhrozek@redhat.com>2014-07-09 17:26:35 +0200
commit842f83f8db513214241a0fea076ac160b180e1dd (patch)
tree89b278a71458c88e048ad08536b93c67305dce0c /Makefile.am
parentd528e4960bf233bc002f9676919ede196c91564c (diff)
downloadsssd-842f83f8db513214241a0fea076ac160b180e1dd.tar.gz
sssd-842f83f8db513214241a0fea076ac160b180e1dd.tar.xz
sssd-842f83f8db513214241a0fea076ac160b180e1dd.zip
BUILD: Link sdap-tests with openldap libraries
sdap-tests uses functions from openldap, but it was not linked with libldap or liblber. sh-4.2$ nm --undefined-only .libs/sdap-tests | grep -E "ldap|ber" U ber_free U ldap_control_create U ldap_err2string U ldap_get_option U ldap_init_fd U ldap_install_tls U ldap_is_ldaps_url U ldap_unbind_ext sdap-tests cannot be linked on platfrms with disabled link_all_deplibs. CCLD sdap-tests /usr/bin/ld: src/providers/ldap/sdap_tests-sdap.o: undefined reference to symbol 'ber_free' /usr/bin/ld: note: 'ber_free' is defined in DSO /lib64/liblber-2.4.so.2 so try adding it to the linker command line /lib64/liblber-2.4.so.2: could not read symbols: Invalid operation clang: error: linker command failed with exit code 1 (use -v to see invocation) make[3]: *** [sdap-tests] Error 1 Reviewed-by: Pavel Reichl <preichl@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ee4b24cf5..8d3d366b4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1904,6 +1904,7 @@ sdap_tests_LDADD = \
$(POPT_LIBS) \
$(SSSD_INTERNAL_LTLIBS) \
$(SSS_CRYPT_LIBS) \
+ $(OPENLDAP_LIBS) \
libsss_test_common.la \
$(NULL)