summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNikolai Kondrashov <Nikolai.Kondrashov@redhat.com>2014-06-19 18:55:34 +0300
committerJakub Hrozek <jhrozek@redhat.com>2014-06-23 19:37:18 +0200
commit6e973aa578a692b2e7597811dfdfdb1a442c85f8 (patch)
tree73f763739d572e73f52783ea97681506fbbb5f1d /Makefile.am
parente504025b074f3e13bbb888272ea1fe11d2bbb8bc (diff)
downloadsssd-6e973aa578a692b2e7597811dfdfdb1a442c85f8.tar.gz
sssd-6e973aa578a692b2e7597811dfdfdb1a442c85f8.tar.xz
sssd-6e973aa578a692b2e7597811dfdfdb1a442c85f8.zip
build: Allow augmenting TESTS_ENVIRONMENT
Add substitution of a special variable "AUX_TESTS_ENVIRONMENT" to the "TESTS_ENVIRONMENT" value, allowing its augmentation from the make command line. This enables wrapping test commands with older versions of Automake, where LOG_COMPILER support is missing. This enables executing "make check" target with Valgrind on RHEL6, like this: make check AUX_TESTS_ENVIRONMENT="libtool --mode=execute valgrind" Reviewed-by: Jakub Hrozek <jhrozek@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2dc4097bf..83999f358 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1077,7 +1077,8 @@ endif
#################
# Feature Tests #
#################
-TESTS_ENVIRONMENT = LDB_MODULES_PATH=$(abs_top_builddir)/ldb_mod_test_dir
+TESTS_ENVIRONMENT = LDB_MODULES_PATH=$(abs_top_builddir)/ldb_mod_test_dir \
+ $(AUX_TESTS_ENVIRONMENT)
ldb_mod_test_dir: memberof.la
mkdir -p $(builddir)/ldb_mod_test_dir