summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNikolai Kondrashov <Nikolai.Kondrashov@redhat.com>2014-09-04 14:04:15 +0300
committerJakub Hrozek <jhrozek@redhat.com>2014-09-22 10:22:17 +0200
commit6398f22526303343193a18e514602f1af6fb29cb (patch)
tree497a1bf764aca87f3c8ac5e0352ce196486f1123 /Makefile.am
parente1a58f3d5b44d4d8b8d0239481eee52c7a9b69fd (diff)
downloadsssd-6398f22526303343193a18e514602f1af6fb29cb.tar.gz
sssd-6398f22526303343193a18e514602f1af6fb29cb.tar.xz
sssd-6398f22526303343193a18e514602f1af6fb29cb.zip
CI: Add Valgrind suppression support
Add an empty Valgrind suppressions file, use it when invoking Valgrind. This prepares for addition of Valgrind suppressions for current false positives and issues that cannot be fixed, preparing for enforcing Valgrind check. Make Valgrind output a suppression for every error and make it output used suppression names and counts at the end of each run. This simplifies discovery and addition of new suppressions and removal of unused ones. Related to https://fedorahosted.org/sssd/ticket/2428 Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b19d69803..86a057229 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -342,7 +342,9 @@ dist_noinst_DATA = \
contrib/ci/configure.sh \
contrib/ci/deps.sh \
contrib/ci/distro.sh \
- contrib/ci/misc.sh
+ contrib/ci/misc.sh \
+ contrib/ci/sssd.supp \
+ $(NULL)
###############################
# Global compilation settings #