summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2014-07-27 14:44:24 +0200
committerJakub Hrozek <jhrozek@redhat.com>2014-10-10 13:56:08 +0200
commit428db8a58c0c149d5efccc6d788f70916c1d34d7 (patch)
tree531147790cdabf2d81b56915bed7e3e29d878efe /Makefile.am
parent40b2be4f4312470044cdef460b02b66003f5c85f (diff)
downloadsssd-428db8a58c0c149d5efccc6d788f70916c1d34d7.tar.gz
sssd-428db8a58c0c149d5efccc6d788f70916c1d34d7.tar.xz
sssd-428db8a58c0c149d5efccc6d788f70916c1d34d7.zip
TESTS: Add a test to change user IDs
Adds a unit test using the nss_wrapper and uid_wrapper libraries that exercises the ability to become another user. Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ac3f26cad..ee6e39ba7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,6 +19,8 @@ if HAVE_MANPAGES
SUBDIRS += src/man
endif
+SUBDIRS += . src/tests/cwrap
+
# Some old versions of automake don't define builddir
builddir ?= .
@@ -2829,6 +2831,7 @@ endif
CLEANFILES = *.X */*.X */*/*.X
tests: all $(check_PROGRAMS)
+ (cd src/tests/cwrap && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
# RPM-related tasks