summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNikolai Kondrashov <Nikolai.Kondrashov@redhat.com>2014-03-25 12:01:00 +0200
committerJakub Hrozek <jhrozek@redhat.com>2014-09-02 10:43:21 +0200
commit3ce85a5f5264e7118beb6524e120fd8b53a13da4 (patch)
treeec46ff937a47518ff9ed0f4dd67ebf2157fbc4bf /Makefile.am
parent6b5044001e4b0a0caf971a2cf5f27674e0d270f4 (diff)
downloadsssd-3ce85a5f5264e7118beb6524e120fd8b53a13da4.tar.gz
sssd-3ce85a5f5264e7118beb6524e120fd8b53a13da4.tar.xz
sssd-3ce85a5f5264e7118beb6524e120fd8b53a13da4.zip
Add basic support for CI test execution
Add basic support for executing continuous integration (CI) tests on RHEL6, RHEL7, Fedora 20, Fedora Rawhide and Debian Testing. This adds two front-end scripts which can be executed either locally by developers, or on a CI server: contrib/ci/run and contrib/ci/clean. The first one will run the tests and the second will wipe out the artifacts. See contrib/ci/README.md for further details. Reviewed-by: Michal Židek <mzidek@redhat.com> Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 1b183d023..869ebb182 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -318,6 +318,11 @@ dist_noinst_SCRIPTS = \
contrib/rhel/update_debug_levels.py \
contrib/fedora/bashrc_sssd \
contrib/fedora/make_srpm.sh \
+ contrib/ci/clean \
+ contrib/ci/make-check-wrap \
+ contrib/ci/rpm-spec-builddeps \
+ contrib/ci/run \
+ contrib/ci/valgrind-condense \
src/tests/pyhbac-test.py \
src/tests/pysss_murmur-test.py
@@ -328,7 +333,12 @@ dist_noinst_DATA = \
src/config/testconfigs/sssd-badversion.conf \
src/config/testconfigs/sssd-invalid.conf \
src/config/testconfigs/sssd-invalid-badbool.conf \
- src/config/etc/sssd.api.d/crash_test_dummy
+ src/config/etc/sssd.api.d/crash_test_dummy \
+ contrib/ci/README.md \
+ contrib/ci/configure.sh \
+ contrib/ci/deps.sh \
+ contrib/ci/distro.sh \
+ contrib/ci/misc.sh
###############################
# Global compilation settings #