summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2014-06-24 17:03:28 +0200
committerJakub Hrozek <jhrozek@redhat.com>2014-07-08 20:38:30 +0200
commit1a59af8245f183f22d87d067a90197d8e2ea958d (patch)
tree306e32f9afa9f2744e1a6110813630a865dde774 /Makefile.am
parent1746e8b8399da2a7a8da4aace186f66055ccfec1 (diff)
downloadsssd-1a59af8245f183f22d87d067a90197d8e2ea958d.tar.gz
sssd-1a59af8245f183f22d87d067a90197d8e2ea958d.tar.xz
sssd-1a59af8245f183f22d87d067a90197d8e2ea958d.zip
BUILD: Add the DBus service activation
The system bus has the ability to start services on demant. This patch adds the sysbus service activation file that, currently, only calls the sss_signal tool to signal the monitor. Reviewed-by: Pavel Březina <pbrezina@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 05b74141b..32af6c069 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -45,6 +45,7 @@ sssdconfdir = $(sysconfdir)/sssd
sssddatadir = $(datadir)/sssd
sssdapiplugindir = $(sssddatadir)/sssd.api.d
dbuspolicydir = $(sysconfdir)/dbus-1/system.d
+dbusservicedir = $(datadir)/dbus-1/system-services
localedir = @localedir@
nsslibdir = @nsslibdir@
pamlibdir = @pammoddir@
@@ -918,6 +919,8 @@ sssd_ifp_LDADD = \
$(SSSD_INTERNAL_LTLIBS)
dist_dbuspolicy_DATA = \
src/responder/ifp/org.freedesktop.sssd.infopipe.conf
+dist_dbusservice_DATA = \
+ src/responder/ifp/org.freedesktop.sssd.infopipe.service
if BUILD_CONFIG_LIB
sssd_ifp_LDADD += libsss_config.la
@@ -2564,6 +2567,7 @@ installsssddirs::
$(DESTDIR)$(pluginpath) \
$(DESTDIR)$(libdir)/ldb \
$(DESTDIR)$(dbuspolicydir) \
+ $(DESTDIR)$(dbusservicedir) \
$(DESTDIR)$(pipepath)/private \
$(DESTDIR)$(sssdlibdir) \
$(DESTDIR)$(pkglibdir) \