summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2014-06-27 17:24:16 +0200
committerJakub Hrozek <jhrozek@redhat.com>2014-07-08 20:38:30 +0200
commit1746e8b8399da2a7a8da4aace186f66055ccfec1 (patch)
tree71b1252532fe27af4bd436a778517b239f9aca01 /Makefile.am
parent149f40dc2d4ead57811c70b5028648ac83f6a1a7 (diff)
downloadsssd-1746e8b8399da2a7a8da4aace186f66055ccfec1.tar.gz
sssd-1746e8b8399da2a7a8da4aace186f66055ccfec1.tar.xz
sssd-1746e8b8399da2a7a8da4aace186f66055ccfec1.zip
TOOLS: New helper tool sss_signal
A minimal tool whose only purpose is to signal the monitor with SIGUSR2. The tool will be executed by the system bus in order to provide system activation, so it's packaged in libexec. Reviewed-by: Pavel Březina <pbrezina@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a5062ed59..05b74141b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -107,7 +107,9 @@ sssdlibexec_PROGRAMS = \
sssd_be \
krb5_child \
ldap_child \
- proxy_child
+ proxy_child \
+ sss_signal \
+ $(NULL)
if BUILD_SUDO
sssdlibexec_PROGRAMS += sssd_sudo
endif
@@ -1048,6 +1050,15 @@ sss_seed_LDADD = \
$(TOOLS_LIBS) \
$(SSSD_INTERNAL_LTLIBS)
+sss_signal_SOURCES = \
+ src/tools/sss_signal.c \
+ $(SSSD_TOOLS_OBJ) \
+ $(NULL)
+sss_signal_LDADD = \
+ $(TOOLS_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ $(NULL)
+
if BUILD_SUDO
sss_sudo_cli_SOURCES = \
src/sss_client/common.c \