summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2014-11-11 15:39:57 +0100
committerJakub Hrozek <jhrozek@redhat.com>2014-11-18 20:49:56 +0100
commit0a039d574ed0e91d939efd2c0975f6a425942afd (patch)
treefe26d3f7eb72e62a137cec08e6c8fb81f62eeeda /Makefile.am
parentf9ac9aa5760210b8bbd3d4e667dff5f101f99d62 (diff)
downloadsssd-0a039d574ed0e91d939efd2c0975f6a425942afd.tar.gz
sssd-0a039d574ed0e91d939efd2c0975f6a425942afd.tar.xz
sssd-0a039d574ed0e91d939efd2c0975f6a425942afd.zip
BUILD: Make chown of files to sssd user non-fatal
In build environments, we can't assume the sssd user will be created prior to installing the package, so we can't chown the files. RPM will own the files instead in this case. Related: https://fedorahosted.org/sssd/ticket/2370 Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 6ce3a42f3..d58fcb950 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2884,12 +2884,12 @@ else
endif
if SSSD_USER
- chgrp $(SSSD_USER) $(sssdlibexecdir)/ldap_child
+ -chgrp $(SSSD_USER) $(sssdlibexecdir)/ldap_child
chmod 4750 $(sssdlibexecdir)/ldap_child
- chgrp $(SSSD_USER) $(sssdlibexecdir)/krb5_child
+ -chgrp $(SSSD_USER) $(sssdlibexecdir)/krb5_child
chmod 4750 $(sssdlibexecdir)/krb5_child
if BUILD_SEMANAGE
- chgrp $(SSSD_USER) $(sssdlibexecdir)/selinux_child
+ -chgrp $(SSSD_USER) $(sssdlibexecdir)/selinux_child
chmod 4750 $(sssdlibexecdir)/selinux_child
endif
endif