summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2015-06-04 11:04:41 +0200
committerJakub Hrozek <jhrozek@redhat.com>2015-06-14 21:47:20 +0200
commitf4025ea817b3467be1c2e6092014a11fe4547c0d (patch)
tree87f4be9e89cbb90ac77be0d23d326e8abecdf207 /Makefile.am
parent78fb1789e8a5c2c7c51ad9002bbbdf0a1e390bdf (diff)
downloadsssd-f4025ea817b3467be1c2e6092014a11fe4547c0d.tar.gz
sssd-f4025ea817b3467be1c2e6092014a11fe4547c0d.tar.xz
sssd-f4025ea817b3467be1c2e6092014a11fe4547c0d.zip
TESTS: Add unit test for the subdomain_server.c module
Reviewed-by: Sumit Bose <sbose@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index db5b23242..4eed1069b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -227,6 +227,7 @@ if HAVE_CMOCKA
test_fo_srv \
pam-srv-tests \
test_ipa_subdom_util \
+ test_ipa_subdom_server \
$(NULL)
if HAVE_LIBRESOLV
@@ -2441,6 +2442,36 @@ test_ipa_subdom_util_LDADD = \
libsss_test_common.la \
$(NULL)
+test_ipa_subdom_server_SOURCES = \
+ $(sssd_be_SOURCES) \
+ $(libsss_krb5_common_la_SOURCES) \
+ src/tests/cmocka/common_mock_sdap.c \
+ src/tests/cmocka/common_mock_be.c \
+ src/tests/cmocka/common_mock_krb5.c \
+ src/tests/cmocka/test_ipa_subdomains_server.c \
+ src/providers/ipa/ipa_subdomains_server.c \
+ src/providers/ipa/ipa_subdomains_utils.c \
+ $(NULL)
+test_ipa_subdom_server_CFLAGS = \
+ $(AM_CFLAGS) \
+ -DUNIT_TESTING \
+ $(NULL)
+test_ipa_subdom_server_LDFLAGS = \
+ -Wl,-wrap,krb5_kt_default \
+ $(NULL)
+test_ipa_subdom_server_LDADD = \
+ $(PAM_LIBS) \
+ $(CMOCKA_LIBS) \
+ $(SSSD_LIBS) \
+ $(CARES_LIBS) \
+ $(KRB5_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ libsss_ldap_common.la \
+ libsss_idmap.la \
+ libsss_ad_common.la \
+ libsss_test_common.la \
+ $(NULL)
+
endif # HAVE_CMOCKA
noinst_PROGRAMS = pam_test_client